Compatibility Matrix

The following documentation is for SuiteCRM Version 8+; to see documentation on the same topic for Version 7, click here.

Versions

SuiteCRM 8.0-beta-3

Platform

Linux, Unix, Mac OS

Any version supporting PHP

PHP

7.3, 7.4, 8.0

Additional requirements for Development

Angular CLI

12+

Node.js

12.14

yarn

1.22.10+

Web Server

Apache

2.2, 2.4

IIS

8, 8.5

Database

MariaDB

10.1+

MySQL

5.6, 5.7, 8

Browsers

Chrome

89+

Firefox

87+

Edge (Chromium)

89+

Safari

14+

SuiteCRM 8.0-beta-2

Platform

Linux, Unix, Mac OS

Any version supporting PHP

PHP

7.3, 7.4, 8.0

Additional requirements for Development

Angular CLI

11+

Node.js

10

yarn

1.22.10+

Web Server

Apache

2.2, 2.4

IIS

8, 8.5

Database

MariaDB

10.1+

MySQL

5.6, 5.7, 8

Browsers

Chrome

89+

Firefox

87+

Edge (Chromium)

89+

Safari

14+

SuiteCRM 8.0-beta-1

Platform

Linux, Unix, Mac OS

Any version supporting PHP

PHP

7.3, 7.4, 8.0

Additional requirements for Development

Angular CLI

11+

Node.js

10

yarn

1.22.10+

Web Server

Apache

2.2, 2.4

IIS

8, 8.5

Database

MariaDB

10.1+

MySQL

5.6, 5.7, 8

Browsers

Chrome

89+

Firefox

87+

Edge (Chromium)

89+

Safari

14+

Content is available under GNU Free Documentation License 1.3 or later unless otherwise noted.